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The dmXLAN system is built-up from DMX/Ethernet nodes / DMX/ethernet recorders and 
intelligent network switches. All of these units can be configured using the free dmXLAN 
software. The software is available on these platforms:
- Windows (XP and Vista)
- Apple Mac OS X (10.4 and up as universal binary)
- Windows Pocket PC 2003 and Windows mobile 5 and up

The software can be used to configure and monitoring the dmXLAN network, and can also 
be used to control/test lighting fixtures connected to the dmXLAN network. All of this is 
independent of the brand of consoles and lighting fixtures used.

Software Setup

Windows

Download the dmXLAN software for windows from the website (www.elclighting.com) and 
unzip the file. Next start the setup.exe program and follow the instructions.

Apple Mac OS X

Download the dmXLAN software for mac from the website (www.elclighitng.com) and 
unzip the file. Next copy the dmXLAN folder to the Applications directory.

Windows Pocket PC 2003

Download the dmXLAN software for poack pc from the website (www.elclighting.com) and 
unzip the file. Next copy the .cab file to the pocket pc. On the pocket pc run the .cab file 
and follow the instructions on the screen. 

Network settings on you computer

The IP address of the computer need to be set to the artnet range:
IP address 2.0.x.x (where x is a value between 1 and 254) 

 Each computer must have a different address.
Netmask 255.0.0.0

Windows

Apple Mac OS X

Windows Pocket PC 2003

Device Connections
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Each network node and switches is connected by standard network topology.
Software description

The software on al platforms work the same. One exception is the pocket pc version, as 
this software uses a different layout and does not support the following functions:
- Plan overview
- Multiple layouts

Note: Mac OS X screen shots are used, but all versions work the same.

Screen layout (Windows and Mac OS X)

The main window has 7 areas:

Plan
This area is always visible and contains an icon for all network nodes, network switches, 
DMX universes and lighting fixtures.

DMX Universe
This area contains a list of all DMX universes. The universes can be automatically 
detected or manually added.

Network
The network area has a list of all network nodes and switches detected on the network. 
Network nodes can also be added manually for configuration in advance.

Fixture



The fixture area is a list of lighting fixtures in the system. These fixture can be manually 
added. From this list you can select one or more fixtures to be controlled.

Log
The log area keeps a list of most event. Each event is marked by a time stamp.
Property
The property area is dynamic. The properties of the selected item (node/universe/
fixture/...) will be displayed here and can be changed. Each change (marked by bold 
characters) must be stored using the “Store” button.

Control
The control area is also dynamic, depending on the selected item. Functions  are 
explained further on.

DMX Universe area

DMX universes on the network are like virtual DMX cables. Each node receives all of 
these cables and can then locally decide to use it or not. The computer also receives the 
DMX data and will display these in the DMX universe list. Each universe in the list shows 
some information about it self:
  ID - The is the identifier (or universe address). For artnet, 2 hexadecimal digits are used. 
Hexadecimal means that each digit has 16 possibilities 0-9, A-F (unlike normally used 
decimal that has 10 possibilities 0-9). With these two digits you can have a maximum of 
256 (16 x 16) different DMX universes on the network. If more then one node or consle on 
the network sends out a DMX universe with the same ID, then there will be a message in 
the log window. The nodes will always only one so it does not switch continually  between 
different DMX sources.
  Name - The name can be given by the user, by using the property area.
  Status - Indicating the actual status of the DMX universe on the network. This can be 
“online” then the universe is active. “Failed” the universe has dissapeared, this might be a 
failed connection or different error. “-” status indicates that the universe has been manually 
added (or loaded from a file) and has not been detected.
  Sender - indicates  the IP address or node name of the source device.
  Port - indicates the port on the sender the universe originates from.
  Channels - channel count in the universe.

Manually adding of universes

To manually add a single or multiple universes, select “Edit > Add DMX Universe” from the 
menu bar.



Next you can set the universe ID, name and number of universes to be added. If you add 
more then 1 universe, then the extension “A”, “B”, etc. is added to the name. Click OK to 
confirm.

View DMX values

To view the channel values of the selected DMX universe select “View > View DMX”. Blue 
bars indicate the value received. Red bars indicate overwritten values. Values can be 
overwritten by the dmXLAN software by using the Universe Control area or Fixture Control 
area.

Universe Properties

By selecting a universe you can change the properties.

Note: When changing the name, youʼll need first to press Enter before pressing store.
 
Universe Control



With the universe control you can overwrite DMX channels on the universes. Use “-> 
Release” to undo the overwriting of channels.

Note: Universe overwrite only works when the final DMX is outputted from a ELC dmXLAN 
node.

Network area

Network nodes and switches can be automatically or manually added. The list shows the 
following information about the device:
  ID - For configuration of the system in advance, youʼll need to use separate IDʼs for each 
device. The ID can then be set in the device and then it will automatically be loaded with 
its new configuration.
  Name - The nodes can be given a meaningful name.
  Status - This indicates the status of the device, this can be 

 “Online” all is OK

 “Failed” connection to the device is lost

 “Program” new configuration is being loaded into the device

 “Read” the current configuration is begin read

 “Verify” the configuration in the device and the software is being compared, done 

 after changing a setting
  Ip Address - network address of the device
  Type - Brand and Type of the device



Network Properties

The properties of each type of node can differ.

The DMX ports of the nodes have 3 types:
- Input
- Output
- Port (omni, can be input or output)

DMX input options

Each DMX input port can be setup as
  Disabled - The port does nothing
  Normal - When the DMX port receives valid DMX, then it will send the DMX data as a 
universe with the specified ID.
  Backup - The input will monitor the network and look out for the specified DMX universe. 
if this universe is nor on the network or has failed, then it will send its own DMX data onto 
the network (only if it receives valid DMX data on itʼs input port). If the same DMX universe 
from a different source (can be the same node, but other input port) is then detected on 
the network, it will stop sending the DMX data. This acts as an automatic switchover.



DMX output options

The output modes are
  Disabled - The DMX output is silent, no DMX signal is outputed
  Out Zero - Send a valid DMX signal with all values at 0 (useful as test signal)
  Single - The DMX output will output the selected (primary) DMX universe.
  Dual HTP - The DMX output will merge 2 universes onto he output with “Highest takes 
Precedence”
  Dual LTP - The DMX output will merge 2 universes onto the output with “Latest takes 
Precedence”.
  Dual Custom - The DMX output is a merge of 2 universes. The merging setup is 
customizable . To customize click on the button (...) in the softpatch field. This wil open the 
“channel config” window.

In the config window you can select a number of channels and set the merge for these 
channel (Primary / Secondary / HTP / LTP). The starting addresses of the two unverses 
(Primary and Secondary) can be adjusted.
  Priority - Define 2 universes for the output. As long as the primary universe is active, then 
this one will be on the output. If the primary fails, then the output will switch to the 
secondary universe. If the primary is back, it will switch back.
  Softpatch - This mode is like the “Dual Custom”, except that the “Channel Config” window  
has changed.



 You can now not only change the starting address of the universe, but softpatch all the 
channels within he universe, or put fixed values instead.

The “Load Template” and “Store Template” buttons can be used for loading and storing the 
patches for use in different nodes.   

Note: The DMX output will start sending DMX after it has detected 1 of the 2 universes on 
the network. The output also features a “DMX hold”. 

Fixture Area

Lighting fixtures can be added manualy via the menu “Edit>Add Fixture”. With the fixtures 
added and patched, will give the dmXLAN operator/rig-tech the abbility to control any 
fixture in the rig without having acces to the console. so the console operator can work 
independant from the techs. Even if there is no console, the tech can sartup and test the 
rig.
The Fixture Area contains the info of the fixtures:
  ID - This is a given number, normaly try to match it to the console fixture IDʼs
  Name - Given name
  Status - the control status (- / controlled / locked) or current macro that is running (lamp 
on / reset)
  Patch - DMX and selected universe (or network node) the fixture is patched to
  Type - Manufacturer name and type of the fixture



In the with Select>Highlight it is possible to enable/disable highlight function. This function 
enable steping thru fixtures

Fixture Properties

The properties of the fixture include name and patch. To patch the fixture, first select 1 or 
multiple fxtures and edit the Patch property. There can be multiple patch properies, for 
fixture types that have splitted DMX areas, like for example the VL5 with external dimmer. 
The patch property indicates the name of the first channel (example the above picture 
“Shutter” is the first channel of the Mac500).
There are 3 posible patch types:
  “Unpatched” - The fixture is not patched, so can not be controlled.
  “Patch to Universe” - The fixture is patched to a universe number. The dmxlan software 
will calculate thru all softpatching and merging to control the fixture.
  “Patch to Node” - This patch indicates exactly whre the fixture is connected and what itʼs 
dmx address is.
The align  property is only used when patching more then 1 fixture. By default the align is 
set to the channel count of the fixture, but it is possible to change this.

Fixture Control



With the fxture control window, all channels and macroʼs can be accessed. The window 
has 4 main tabʼs: Basic / Colour / Beam / Extra each containing the related channels.
The basic tab also has Control buttons:
  Release - release the fixture back to to the main console
  On - set the fixture to a default “on” state (intensity full, shutter open and pan/tilt to 50%)  
  Lock - remove the fixture from the show (intensity 0%, shutter close and pan/tilt to 50%)  
The macro area can be used to run macroʼs like lamp on / lamp off or reset. When running 
a macro onto multiple fixtures, each macro will be time delayed, this to prevent a power 
surge.

Fixture type library files

The library file is made up from a basic file ʻfixture.libʼ, this is a text file which can include 
sub text files. All files are found in the “Program Files\Elclighting\dmXLAN 3.x.x\Fixture 
Library” directory.

Example of the main fixture.lib file

fixture = Profile
image = profile
parameter = Intensity

fixture = Par
image = par
parameter = Intensity

fixture = Dimmer 12ch
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity
parameter = Intensity

#include = "martin.lib"
#include = "claypaky.lib"
#include = "highend.lib"

To define a fixture first set its manufacturer, followed by the fixture type name and the 
image item sets the name of the icon type.

Example of the high end file, only one fixture shown (studio spot 250)

manufacturer = High End

fixture = Studio Spot 250
head = yoke
image = yoke

parameter = Pan



default = 128
parameter = Pan, fine
parameter = Tilt
default = 128
parameter = Tilt, fine

parameter = Colour 1 Mode
parameter = Colour 1
parameter = Gobo 1 Mode
parameter = Gobo 1
parameter = Gobo 1 <>
parameter = Prism
parameter = Prism <>
parameter = Focus
parameter = Iris
parameter = Shutter
highlight = 255
default = 255
parameter = Intensity
highlight = 255
parameter = Speed 1
parameter = Macro
parameter = Control

macro = Reset
step = set, Shutter, 0
step = set, Control, 64
step = delay, 2
step = release, all
macro = Lamp On
step = set, Shutter, 0
step = set, Control, 84
step = delay, 2
step = release, all
macro = Lamp Off
step = set, Shutter, 0
step = set, Control, 94
step = delay, 2
step = release, all
macro = Display Off
step = set, Shutter, 0
step = set, Control, 24
step = delay, 2
step = release, all
macro = Display Dim
step = set, Shutter, 0
step = set, Control, 34
step = delay, 2
step = release, all
macro = Display On
step = set, Shutter, 0
step = set, Control, 44
step = delay, 2
step = release, all
macro = Shutdown
step = set, Shutter, 0
step = set, Control, 124
step = delay, 4
step = release, all



Parameters are added in the DMX channel order. Fine means that is the fine channel of 
the parameter. Add break if the fixture has more then one DMX range, for example a VL5 
has a separate dimmer.

parameter = name [, fine] [, break]

A default can be added (if the value is not 0), this value is used when disabling the fixture

default = value

A value can be given to be used when highlighting the fixture

highlight = value

after all parameters are done, macros can be added to the fixture

macro = name

and then macro steps 

step = set, name_of_parameter, value
 
 set a channel to the value
step = delay, seconds
 
 
 
 delay for number of seconds
step = release, name_of _parameter or all
 release a single parameter or all


